CVE-2014-4617

NameCVE-2014-4617
DescriptionThe do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-0012-1, DLA-51-1, DSA-2967-1, DSA-2968-1
Debian Bugs752497, 752498

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg2 (PTS)buster, buster (security)2.2.12-1+deb10u2fixed
bullseye (security), bullseye2.2.27-2+deb11u2fixed
bookworm2.2.40-1.1fixed
trixie2.2.40-3fixed
sid2.2.43-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupgsourcesqueeze1.4.10-4+squeeze5
gnupgsourcewheezy1.4.12-7+deb7u4DSA-2967-1
gnupgsource(unstable)1.4.16-1.2752497
gnupg2sourcesqueeze2.0.14-2+squeeze2DLA-51-1
gnupg2sourcewheezy2.0.19-2+deb7u2DSA-2968-1
gnupg2source(unstable)2.0.24-1752498

Notes

http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=11fdfcf82bd8

Search for package or bug name: Reporting problems