CVE-2014-4659

NameCVE-2014-4659
DescriptionAnsible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the "deb http://user:pass@server:port/" format.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)stretch2.2.1.0-2+deb9u1fixed
stretch (security)2.2.1.0-2+deb9u2fixed
buster2.7.7+dfsg-1fixed
buster (security)2.7.7+dfsg-1+deb10u1fixed
bookworm, sid, bullseye2.10.7+merged+base+2.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)1.5.5+dfsg-1

Notes

https://github.com/ansible/ansible/commit/c4b5e46054c74176b2446c82d4df1a2610eddc08

Search for package or bug name: Reporting problems