CVE-2014-4720

NameCVE-2014-4720
DescriptionEmail::Address module before 1.904 for Perl uses an inefficient regular expression, which allows remote attackers to cause a denial of service (CPU consumption) via vectors related to "backtracking into the phrase," a different vulnerability than CVE-2014-0477.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2969-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage libemail-address-perl is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libemail-address-perl (PTS)squeeze1.889-2vulnerable
squeeze (lts)1.889-2+deb6u1fixed
wheezy (security), wheezy1.895-1+deb7u1fixed
jessie1.905-2fixed
stretch, sid1.907-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libemail-address-perlsource(unstable)1.905-1medium
libemail-address-perlsourcesqueeze1.889-2+deb6u1medium
libemail-address-perlsourcewheezy1.895-1+deb7u1mediumDSA-2969-1

Search for package or bug name: Reporting problems