CVE-2014-4877

NameCVE-2014-4877
DescriptionAbsolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary files, and consequently execute arbitrary code, via a LIST response that references the same filename within two entries, one of which indicates that the filename is for a symlink.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-82-1, DSA-3062-1
NVD severityhigh (attack range: remote)
Debian Bugs766981

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)wheezy1.13.4-3+deb7u2fixed
wheezy (security)1.13.4-3+deb7u4fixed
jessie1.16-1+deb8u2fixed
stretch1.18-5fixed
buster, sid1.19.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)1.16-1high766981
wgetsourcesqueeze1.12-2.1+deb6u1highDLA-82-1
wgetsourcewheezy1.13.4-3+deb7u2highDSA-3062-1

Notes

http://git.savannah.gnu.org/cgit/wget.git/commit/?id=18b0979357ed7dc4e11d4f2b1d7e0f5932d82aa7

Search for package or bug name: Reporting problems