CVE-2014-4911

NameCVE-2014-4911
DescriptionThe ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-36-1, DSA-2981-1
NVD severitymedium (attack range: remote)
Debian Bugs754655

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
polarssl (PTS)wheezy, wheezy (security)1.2.9-1~deb7u6fixed
jessie1.3.9-2.1+deb8u2fixed
jessie (security)1.3.9-2.1+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
polarsslsource(unstable)1.3.7-2.1medium754655
polarsslsourcesqueeze1.2.9-1~deb6u2medium
polarsslsourcewheezy1.2.9-1~deb7u3mediumDSA-2981-1

Notes

https://polarssl.org/tech-updates/security-advisories/polarssl-security-advisory-2014-02
commit for 1.3.x branch: https://github.com/polarssl/polarssl/commit/0bcc4e1df78fff6d15c3ecb521e3bd0bbee86e1c
commit for 1.2.x branch: https://github.com/polarssl/polarssl/commit/5bad6afd8c72b2c3a6574dff01ca5f8f2f04800a

Search for package or bug name: Reporting problems