CVE-2014-4914

NameCVE-2014-4914
DescriptionThe Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-251-1, DSA-3265-1
NVD severityhigh (attack range: remote)
Debian Bugs754201

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zendframework (PTS)jessie1.12.9+dfsg-2+deb8u6fixed
jessie (security)1.12.9+dfsg-2+deb8u7fixed
sid1.12.20+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zendframeworksource(unstable)1.12.7-0.1high754201
zendframeworksourcesqueeze1.10.6-1squeeze3highDLA-251-1
zendframeworksourcewheezy1.11.13-1.1+deb7u1highDSA-3265-1

Notes

http://framework.zend.com/security/advisory/ZF2014-04
https://github.com/zendframework/zf1/commit/da09186c60b9168520e994af4253fba9c19c2b3d

Search for package or bug name: Reporting problems