CVE-2014-4943

NameCVE-2014-4943
DescriptionThe PPPoL2TP feature in net/l2tp/l2tp_ppp.c in the Linux kernel through 3.15.6 allows local users to gain privileges by leveraging data-structure differences between an l2tp socket and an inet socket.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-103-1, DSA-2992-1
NVD severitymedium (attack range: local)
Debian/oldstablepackage linux-2.6 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.65-1fixed
wheezy (security)3.2.65-1+deb7u2fixed
jessie, sid3.16.7-ckt4-3fixed
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6vulnerable
squeeze (lts)2.6.32-48squeeze11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.14.13-1medium
linuxsourcewheezy3.2.60-1+deb7u3mediumDSA-2992-1
linux-2.6source(unstable)(unfixed)medium
linux-2.6sourcesqueeze2.6.32-48squeeze9mediumDLA-103-1

Notes

upstream commit: https://git.kernel.org/linus/3cf521f7dc87c031617fd47e4b7aa2593c2f3daf

Search for package or bug name: Reporting problems