CVE-2014-4966

NameCVE-2014-4966
DescriptionAnsible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)buster, buster (security)2.7.7+dfsg-1+deb10u1fixed
bullseye2.10.7+merged+base+2.10.8+dfsg-1fixed
bookworm7.0.0+dfsg-1fixed
sid7.0.0+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)1.6.8+dfsg-1

Notes

https://github.com/ansible/ansible/commit/84759faa0950146a6bae8452580b4a4cede6d871

Search for package or bug name: Reporting problems