CVE-2014-4975

NameCVE-2014-4975
DescriptionOff-by-one error in the encodes function in pack.c in Ruby 1.9.3 and earlier, and 2.x through 2.1.2, when using certain format string specifiers, allows context-dependent attackers to cause a denial of service (segmentation fault) via vectors that trigger a stack-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-200-1, DSA-3157-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5fixed
wheezy (security)1.9.3.194-8.1+deb7u6fixed
ruby2.1 (PTS)jessie2.1.5-2+deb8u3fixed
jessie (security)2.1.5-2+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(not affected)
ruby1.9.1source(unstable)(unfixed)low
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u3mediumDLA-200-1
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u3mediumDSA-3157-1
ruby2.0source(unstable)(unfixed)low
ruby2.1source(unstable)2.1.3-1low

Notes

- ruby1.8 <not-affected> (Vulnerable code not present in 1.8)
[wheezy] - ruby1.9.1 <no-dsa> (Minor issue)
http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=46778

Search for package or bug name: Reporting problems