CVE-2014-5019

NameCVE-2014-5019
DescriptionThe multisite feature in Drupal 6.x before 6.32 and 7.x before 7.29 allows remote attackers to cause a denial of service via a crafted HTTP Host header, related to determining which configuration file to use.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2983-1
NVD severitymedium (attack range: remote)
Debian Bugs755038
Debian/oldoldstablepackage drupal6 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal6 (PTS)squeeze, squeeze (security)6.31-1vulnerable
drupal7 (PTS)wheezy7.14-2+deb7u8fixed
wheezy (security)7.14-2+deb7u10fixed
jessie7.32-1+deb8u3fixed
jessie (security)7.32-1+deb8u4fixed
stretch, sid7.38-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(unfixed)medium
drupal6sourcesqueeze(unfixed)end-of-life
drupal7source(unstable)7.29-1medium755038
drupal7sourcewheezy7.14-2+deb7u5mediumDSA-2983-1

Notes

https://www.drupal.org/SA-CORE-2014-003

Search for package or bug name: Reporting problems