CVE-2014-5022

NameCVE-2014-5022
DescriptionCross-site scripting (XSS) vulnerability in the Ajax system in Drupal 7.x before 7.29 allows remote attackers to inject arbitrary web script or HTML via vectors involving forms with an Ajax-enabled textfield and a file field.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2983-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs755038
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal6 (PTS)squeeze, squeeze (security)6.31-1fixed
drupal7 (PTS)wheezy7.14-2+deb7u8fixed
wheezy (security)7.14-2+deb7u10fixed
jessie7.32-1+deb8u3fixed
jessie (security)7.32-1+deb8u4fixed
stretch, sid7.38-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(not affected)
drupal7source(unstable)7.29-1medium755038
drupal7sourcewheezy7.14-2+deb7u5mediumDSA-2983-1

Notes

- drupal6 <not-affected> (Only affects Drupal 7 core)
https://www.drupal.org/SA-CORE-2014-003

Search for package or bug name: Reporting problems