CVE-2014-5025

NameCVE-2014-5025
DescriptionCross-site scripting (XSS) vulnerability in data_sources.php in Cacti 0.8.8b allows remote authenticated users with console access to inject arbitrary web script or HTML via the name_cache parameter in a ds_edit action.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-40-1, DSA-3007-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcesqueeze0.8.7g-1+squeeze5DLA-40-1
cactisourcewheezy0.8.8a+dfsg-5+deb7u4DSA-3007-1
cactisource(unstable)0.8.8b+dfsg-7

Notes

http://bugs.cacti.net/view.php?id=2456

Search for package or bug name: Reporting problems