CVE-2014-5204

NameCVE-2014-5204
Descriptionwp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-56-1, DSA-3001-1
NVD severitymedium (attack range: remote)
Debian Bugs757312

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u19fixed
jessie (security), jessie4.1+dfsg-1+deb8u15fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u1fixed
buster, sid4.9.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)3.9.2+dfsg-1medium757312
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u5mediumDLA-56-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u4mediumDSA-3001-1

Notes

https://core.trac.wordpress.org/changeset/29384

Search for package or bug name: Reporting problems