CVE-2014-5242

NameCVE-2014-5242
DescriptionCross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22.x before 1.22.9 and 1.23.x before 1.23.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving the multipageimagenavbox class in conjunction with an action=raw value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2fixed
buster (security)1:1.31.16-1+deb10u7fixed
bullseye1:1.35.13-1~deb11u1fixed
bullseye (security)1:1.35.13-1+deb11u2fixed
bookworm1:1.39.5-1~deb12u1fixed
bookworm (security)1:1.39.7-1~deb12u1fixed
sid, trixie1:1.39.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)(not affected)

Notes

- mediawiki <not-affected> (Vulnerable code not present)
https://bugzilla.wikimedia.org/show_bug.cgi?id=66608
Introduced in 1.22wmf14, https://bugzilla.wikimedia.org/show_bug.cgi?id=66608#c18

Search for package or bug name: Reporting problems