CVE-2014-5247

NameCVE-2014-5247
DescriptionThe _UpgradeBeforeConfigurationChange function in lib/client/gnt_cluster.py in Ganeti 2.10.0 before 2.10.7 and 2.11.0 before 2.11.5 uses world-readable permissions for the configuration backup file, which allows local users to obtain SSL keys, remote API credentials, and other sensitive information by reading the file, related to the upgrade command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ganeti (PTS)stretch2.15.2-7+deb9u3fixed
buster2.16.0-5fixed
bullseye3.0.1-2fixed
bookworm, sid3.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ganetisourcesqueeze(not affected)
ganetisourcewheezy(not affected)
ganetisource(unstable)2.11.5-1

Notes

[wheezy] - ganeti <not-affected> (Vulnerable code not present)
[squeeze] - ganeti <not-affected> (Vulnerable code not present)
http://www.ocert.org/advisories/ocert-2014-006.html

Search for package or bug name: Reporting problems