CVE-2014-5262

NameCVE-2014-5262
DescriptionSQL injection vulnerability in the graph settings script (graph_settings.php) in Cacti 0.8.8b and earlier allows remote attackers to execute arbitrary SQL commands via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-40-1, DSA-3007-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)wheezy0.8.8a+dfsg-5+deb7u8fixed
wheezy (security)0.8.8a+dfsg-5+deb7u10fixed
jessie0.8.8b+dfsg-8+deb8u6fixed
jessie (security)0.8.8b+dfsg-8+deb8u4fixed
stretch0.8.8h+ds1-10fixed
buster, sid1.1.25+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)0.8.8b+dfsg-8high
cactisourcesqueeze0.8.7g-1+squeeze5highDLA-40-1
cactisourcewheezy0.8.8a+dfsg-5+deb7u4highDSA-3007-1

Notes

http://svn.cacti.net/viewvc?view=rev&revision=7454

Search for package or bug name: Reporting problems