CVE-2014-5265

NameCVE-2014-5265
DescriptionThe Incutio XML-RPC (IXR) Library, as used in WordPress before 3.9.2 and Drupal 6.x before 6.33 and 7.x before 7.31, permits entity declarations without considering recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-56-1, DSA-2999-1, DSA-3001-1
NVD severitymedium (attack range: remote)
Debian Bugs757312

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)jessie (security), jessie7.32-1+deb8u12fixed
stretch (security), stretch7.52-2+deb9u4fixed
wordpress (PTS)jessie (security), jessie4.1+dfsg-1+deb8u17fixed
stretch4.7.5+dfsg-2+deb9u3fixed
stretch (security)4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.7+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(unfixed)medium
drupal6sourcesqueeze(unfixed)end-of-life
drupal7source(unstable)7.31-1medium
drupal7sourcewheezy7.14-2+deb7u6mediumDSA-2999-1
wordpresssource(unstable)3.9.2+dfsg-1medium757312
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u5mediumDLA-56-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u4mediumDSA-3001-1

Notes

https://core.trac.wordpress.org/changeset/29405/branches/3.9
https://www.drupal.org/SA-CORE-2014-004

Search for package or bug name: Reporting problems