CVE-2014-5266

NameCVE-2014-5266
DescriptionThe Incutio XML-RPC (IXR) Library, as used in WordPress before 3.9.2 and Drupal 6.x before 6.33 and 7.x before 7.31, does not limit the number of elements in an XML document, which allows remote attackers to cause a denial of service (CPU consumption) via a large document, a different vulnerability than CVE-2014-5265.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-56-1, DSA-2999-1, DSA-3001-1
NVD severitymedium (attack range: remote)
Debian Bugs757312

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)wheezy7.14-2+deb7u12fixed
wheezy (security)7.14-2+deb7u16fixed
jessie (security), jessie7.32-1+deb8u9fixed
stretch (security), stretch7.52-2+deb9u1fixed
buster, sid7.56-1fixed
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u19fixed
jessie (security), jessie4.1+dfsg-1+deb8u15fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u1fixed
buster, sid4.9.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(unfixed)medium
drupal6sourcesqueeze(unfixed)end-of-life
drupal7source(unstable)7.31-1medium
drupal7sourcewheezy7.14-2+deb7u6mediumDSA-2999-1
wordpresssource(unstable)3.9.2+dfsg-1medium757312
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u5mediumDLA-56-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u4mediumDSA-3001-1

Notes

https://core.trac.wordpress.org/changeset/29405/branches/3.9
https://www.drupal.org/SA-CORE-2014-004

Search for package or bug name: Reporting problems