CVE-2014-5270

NameCVE-2014-5270
DescriptionLibgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-54-1, DLA-93-1, DSA-3024-1, DSA-3073-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg (PTS)wheezy1.4.12-7+deb7u7fixed
wheezy (security)1.4.12-7+deb7u9fixed
jessie1.4.18-7+deb8u3fixed
jessie (security)1.4.18-7+deb8u4fixed
libgcrypt11 (PTS)wheezy1.5.0-5+deb7u4fixed
wheezy (security)1.5.0-5+deb7u6fixed
libgcrypt20 (PTS)jessie (security), jessie1.6.3-2+deb8u4fixed
stretch (security), stretch1.7.6-2+deb9u2fixed
buster, sid1.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupgsource(unstable)1.4.16-1low
gnupgsourcesqueeze1.4.10-4+squeeze6lowDLA-54-1
gnupgsourcewheezy1.4.12-7+deb7u6lowDSA-3024-1
libgcrypt11source(unstable)1.5.4-1low
libgcrypt11sourcesqueeze1.4.5-2+squeeze2lowDLA-93-1
libgcrypt11sourcewheezy1.5.0-5+deb7u2lowDSA-3073-1
libgcrypt20source(unstable)1.6.0-2low

Notes

http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commit;h=cad8216f9a0b33c9dc84ecc4f385b00045e7b496
http://lists.gnupg.org/pipermail/gnupg-announce/2014q3/000352.html

Search for package or bug name: Reporting problems