DescriptionHeap-based buffer overflow in the encode_slice function in libavcodec/proresenc_kostya.c in FFMpeg before 1.1.14, 1.2.x before 1.2.8, 2.x before 2.2.7, and 2.3.x before 2.3.3 and Libav before 10.5 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)bullseye7:4.3.6-0+deb11u1fixed
bullseye (security)7:4.3.7-0+deb11u1fixed
bookworm, bookworm (security)7:5.1.5-0+deb12u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)(not affected)
libavsourcewheezy(not affected)


- ffmpeg <not-affected> (Vulnerable code not present)
[wheezy] - libav <not-affected> (Vulnerable code not present);a=commit;h=52b81ff4635c077b2bc8b8d3637d933b6629d803
new ffmpeg now in experimental, CVE fixed in 7:2.4-1;a=commitdiff;h=45ce880a9b3e50cfa088f111dffaf8685bd7bc6b

Search for package or bug name: Reporting problems