CVE-2014-5388

NameCVE-2014-5388
DescriptionOff-by-one error in the pci_read function in the ACPI PCI hotplug interface (hw/acpi/pcihp.c) in QEMU allows local guest users to obtain sensitive information and have other unspecified impact related to a crafted PCI device that triggers memory corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemusource(unstable)2.1+dfsg-5
qemu-kvmsourcesqueeze(not affected)
qemu-kvmsourcewheezy(not affected)
qemu-kvmsource(unstable)(unfixed)

Notes

[squeeze] - qemu <not-affected> (Introduced in 1.7)
[wheezy] - qemu <not-affected> (Introduced in 1.7)
[squeeze] - qemu-kvm <not-affected> (Introduced in 1.7)
[wheezy] - qemu-kvm <not-affected> (Introduced in 1.7)
https://lists.gnu.org/archive/html/qemu-devel/2014-08/msg03338.html
Introduced in http://git.qemu.org/?p=qemu.git;a=commit;h=db4728e6fec0364b866d3106125974eedc00e091

Search for package or bug name: Reporting problems