CVE-2014-6272

NameCVE-2014-6272
DescriptionMultiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2015-6525 for the functions that are only affected in 2.0 and later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-137-1, DSA-3119-1
NVD severityhigh (attack range: remote)
Debian Bugs774645

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libevent (PTS)wheezy2.0.19-stable-3+deb7u1fixed
wheezy (security)2.0.19-stable-3+deb7u2fixed
jessie (security), jessie2.0.21-stable-2+deb8u1fixed
stretch2.0.21-stable-3fixed
buster, sid2.1.8-stable-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libeventsource(unstable)2.0.21-stable-2high774645
libeventsourcesqueeze1.4.13-stable-1+deb6u1highDLA-137-1
libeventsourcewheezy2.0.19-stable-3+deb7u1highDSA-3119-1

Search for package or bug name: Reporting problems