CVE-2014-6273

NameCVE-2014-6273
DescriptionBuffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-58-1, DSA-3031-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apt (PTS)wheezy0.9.7.9+deb7u7fixed
wheezy (security)0.9.7.9+deb7u6fixed
jessie (security), jessie1.0.9.8.4fixed
stretch1.4.8fixed
buster, sid1.6~alpha5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aptsource(unstable)1.0.3medium
aptsourcesqueeze0.8.10.3+squeeze5mediumDLA-58-1
aptsourcewheezy0.9.7.9+deb7u5mediumDSA-3031-1

Search for package or bug name: Reporting problems