CVE-2014-6277

NameCVE-2014-6277
DescriptionGNU Bash through 4.3 bash43-026 does not properly parse function definitions in the values of environment variables, which allows remote attackers to execute arbitrary code or cause a denial of service (uninitialized memory access, and untrusted-pointer read and write operations) via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271 and CVE-2014-7169.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bash (PTS)wheezy4.2+dfsg-0.1+deb7u3fixed
wheezy (security)4.2+dfsg-0.1+deb7u4fixed
jessie4.3-11+deb8u1fixed
buster, sid, stretch4.4-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bashsource(unstable)4.3-9.2high
bashsourcesqueeze4.1-3+deb6u2high
bashsourcewheezy4.2+dfsg-0.1+deb7u3high

Notes

Florian Weimer's variables-affix.patch patch applied in Debian prevents
exploitation of this issue by making bash only use environment variables
with specific names (BASH_FUNC_*()) to define functions from its
environment.

Search for package or bug name: Reporting problems