CVE-2014-6310

NameCVE-2014-6310
DescriptionBuffer overflow in CHICKEN 4.9.0 and 4.9.0.1 may allow remote attackers to execute arbitrary code via the 'select' function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chicken (PTS)stretch4.11.0-1fixed
buster4.13.0-1fixed
bullseye, sid5.2.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chickensource(unstable)(not affected)

Notes

- chicken <not-affected> (Affects only CHICKEN Scheme on the Android platform)

Search for package or bug name: Reporting problems