CVE-2014-6387

NameCVE-2014-6387
Descriptiongpc_api.php in MantisBT 1.2.17 and earlier allows remote attackers to bypass authenticated via a password starting will a null byte, which triggers an unauthenticated bind.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3120-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mantis (PTS)wheezy1.2.18-1fixed
wheezy (security)1.2.18-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mantissource(unstable)(unfixed)medium
mantissourcesqueeze(unfixed)end-of-life
mantissourcewheezy1.2.18-1mediumDSA-3120-1

Notes

[squeeze] - mantis <end-of-life> (Unsupported in squeeze-lts)
http://www.mantisbt.org/bugs/view.php?id=17640
http://github.com/mantisbt/mantisbt/commit/215968fa8 (1.2.x branch)
http://github.com/mantisbt/mantisbt/commit/fc02c46ee (master branch)

Search for package or bug name: Reporting problems