CVE-2014-6438

NameCVE-2014-6438
DescriptionThe URI.decode_www_form_component method in Ruby before 1.9.2-p330 allows remote attackers to cause a denial of service (catastrophic regular expression backtracking, resource consumption, or application crash) via a crafted string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-275-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5fixed
wheezy (security)1.9.3.194-8.1+deb7u6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(not affected)
ruby1.9.1source(unstable)1.9.3.0-1medium
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u6mediumDLA-275-1

Notes

- ruby1.8 <not-affected> (Vulnerable code not present)
https://www.ruby-lang.org/en/news/2014/08/19/ruby-1-9-2-p330-released/
https://github.com/ruby/www.ruby-lang.org/issues/817
https://github.com/ruby/ruby/commit/5082e91876502a2f3dde862406a0efe9f85afcdb
https://github.com/ruby/ruby/commit/7b9354af8805c02ed968765abe300162e0fcc943
CVE assignment is specific to ruby 1.9.x series?

Search for package or bug name: Reporting problems