CVE-2014-6440

NameCVE-2014-6440
DescriptionVideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie (security), jessie2.2.6-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
buster2.2.6-6fixed
sid2.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)2.1.5-1low
vlcsourcesqueeze(unfixed)end-of-life
vlcsourcewheezy(not affected)

Notes

[wheezy] - vlc <not-affected> (Introduced in 2.1)
[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems