CVE-2014-7144

NameCVE-2014-7144
DescriptionOpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs762748, 762749

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-keystoneclient (PTS)stretch1:3.2.0-4fixed
buster1:3.17.0-2fixed
bullseye1:4.1.1-2fixed
bookworm, sid1:4.3.0-2fixed
python-keystonemiddleware (PTS)stretch4.9.0-2fixed
buster5.2.0-2fixed
bullseye9.1.0-2fixed
bookworm, sid9.3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-keystoneclientsource(unstable)1:0.10.1-2762749
python-keystonemiddlewaresource(unstable)1.0.0-3762748

Notes

[wheezy] - python-keystoneclient <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems