CVE-2014-7146

NameCVE-2014-7146
DescriptionThe XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to execute arbitrary PHP code via a crafted (1) description field or (2) issuelink attribute in an XML file, which is not properly handled when executing the preg_replace function with the e modifier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3120-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mantis (PTS)wheezy1.2.18-1fixed
wheezy (security)1.2.18-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mantissource(unstable)(unfixed)high
mantissourcesqueeze(unfixed)end-of-life
mantissourcewheezy1.2.18-1highDSA-3120-1

Notes

[squeeze] - mantis <end-of-life> (Unsupported in squeeze-lts)
http://www.mantisbt.org/bugs/view.php?id=17725
https://github.com/mantisbt/mantisbt/commit/bed19db9 (1.2.x branch)
https://github.com/mantisbt/mantisbt/commit/84017535 (master)

Search for package or bug name: Reporting problems