CVE-2014-7169

NameCVE-2014-7169
DescriptionGNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed function definitions in the values of environment variables, which allows remote attackers to write to files or possibly have unknown other impact via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-63-1, DSA-3035-1
NVD severityhigh
Debian Bugs762760

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bash (PTS)jessie4.3-11+deb8u1fixed
jessie (security)4.3-11+deb8u2fixed
stretch4.4-5fixed
buster5.0-4fixed
bullseye, sid5.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bashsource(unstable)4.3-9.2762760
bashsourcesqueeze4.1-3+deb6u2DLA-63-1
bashsourcewheezy4.2+dfsg-0.1+deb7u3DSA-3035-1

Search for package or bug name: Reporting problems