CVE-2014-7818

NameCVE-2014-7818
DescriptionDirectory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.20, 4.0.x before 4.0.11, 4.1.x before 4.1.7, and 4.2.x before 4.2.0.beta3, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via a /..%2F sequence.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs770934

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)stretch2:4.2.7.1-1+deb9u2fixed
stretch (security)2:4.2.7.1-1+deb9u5fixed
buster, buster (security)2:5.2.2.1+dfsg-1+deb10u3fixed
bullseye2:6.0.3.7+dfsg-2fixed
bookworm, sid2:6.1.4.6+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourcesqueeze(not affected)
railssourcewheezy(not affected)
railssource(unstable)2:4.1.8-1770934
rails-3.2source(unstable)(unfixed)
ruby-actionpack-2.3source(unstable)(not affected)
ruby-actionpack-3.2source(unstable)(unfixed)

Notes

[wheezy] - rails <not-affected> (src:rails in wheezy is just a transition package)
[squeeze] - rails <not-affected> (Only affects >= 3)
[wheezy] - ruby-actionpack-3.2 <no-dsa> (Minor issue)
- ruby-actionpack-2.3 <not-affected> (Only affects >= 3)

Search for package or bug name: Reporting problems