CVE-2014-7824

NameCVE-2014-7824
DescriptionD-Bus 1.3.0 through 1.6.x before 1.6.26, 1.8.x before 1.8.10, and 1.9.x before 1.9.2 allows local users to cause a denial of service (prevention of new connections and connection drop) by queuing the maximum number of file descriptors. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3636.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3099-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)buster1.12.20-0+deb10u1fixed
buster (security)1.12.28-0+deb10u1fixed
bullseye1.12.28-0+deb11u1fixed
bullseye (security)1.12.24-0+deb11u1fixed
bookworm1.14.10-1~deb12u1fixed
trixie, sid1.14.10-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussourcesqueeze(not affected)
dbussourcewheezy1.6.8-1+deb7u5DSA-3099-1
dbussource(unstable)1.8.10-1

Notes

[squeeze] - dbus <not-affected> (dbus 1.2.x does not support FD passing)
Since this CVE is only a complement for the fix to CVE-2014-3636, versions not affected by CVE-2014-3636 do not need the patch provided for this CVE.

Search for package or bug name: Reporting problems