CVE-2014-7829

NameCVE-2014-7829
DescriptionDirectory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.21, 4.0.x before 4.0.12, 4.1.x before 4.1.8, and 4.2.x before 4.2.0.beta4, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via vectors involving a \ (backslash) character, a similar issue to CVE-2014-7818.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs770934

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster2:4.2.10-1fixed
sid2:5.2.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.1.8-1medium770934
railssourcesqueeze(not affected)
railssourcewheezy(not affected)
rails-3.2source(unstable)(unfixed)medium
ruby-actionpack-2.3source(unstable)(not affected)
ruby-actionpack-3.2source(unstable)(unfixed)medium

Notes

[wheezy] - rails <not-affected> (src:rails in wheezy is just a transition package)
[squeeze] - rails <not-affected> (Only affects >= 3)
[wheezy] - ruby-actionpack-3.2 <no-dsa> (Minor issue)
- ruby-actionpack-2.3 <not-affected> (Only affects >= 3)

Search for package or bug name: Reporting problems