CVE-2014-8090

NameCVE-2014-8090
DescriptionThe REXML parser in Ruby 1.9.x before 1.9.3 patchlevel 551, 2.0.x before 2.0.0 patchlevel 598, and 2.1.x before 2.1.5 allows remote attackers to cause a denial of service (CPU and memory consumption) a crafted XML document containing an empty string in an entity that is used in a large number of nested entity references, aka an XML Entity Expansion (XEE) attack. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-1821 and CVE-2014-8080.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-200-1, DLA-88-1, DSA-3157-1, DSA-3159-1
NVD severitymedium (attack range: remote)
Debian Bugs770932

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5fixed
wheezy (security)1.9.3.194-8.1+deb7u6fixed
ruby2.1 (PTS)jessie2.1.5-2+deb8u3fixed
jessie (security)2.1.5-2+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(not affected)
ruby1.8sourcesqueeze1.8.7.302-2squeeze3mediumDLA-88-1
ruby1.8sourcewheezy1.8.7.358-7.1+deb7u2mediumDSA-3159-1
ruby1.9.1source(unstable)(not affected)
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u3mediumDLA-200-1
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u3mediumDSA-3157-1
ruby2.0source(unstable)(not affected)
ruby2.1source(unstable)2.1.5-1medium770932

Notes

- ruby1.8 <not-affected> (Incomplete fix never relesed for 1.9)
- ruby1.9.1 <not-affected> (Incomplete fix never relesed for 1.9)
- ruby2.0 <not-affected> (Incomplete fix never relesed for 1.9)
For the incomplete fix for CVE-2014-8080
https://www.ruby-lang.org/en/news/2014/11/13/rexml-dos-cve-2014-8090/

Search for package or bug name: Reporting problems