CVE-2014-8094

NameCVE-2014-8094
DescriptionInteger overflow in the ProcDRI2GetBuffers function in the DRI2 extension in X.Org Server (aka xserver and xorg-server) 1.7.0 through 1.16.x before 1.16.3 allows remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via a crafted request, which triggers an out-of-bounds read or write.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-120-1, DSA-3095-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)wheezy2:1.12.4-6+deb7u6fixed
wheezy (security)2:1.12.4-6+deb7u8fixed
jessie (security), jessie2:1.16.4-1+deb8u2fixed
stretch (security), stretch2:1.19.2-1+deb9u2fixed
buster, sid2:1.19.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.16.2.901-1medium
xorg-serversourcesqueeze2:1.7.7-18+deb6u1mediumDLA-120-1
xorg-serversourcewheezy2:1.12.4-6+deb7u5mediumDSA-3095-1

Search for package or bug name: Reporting problems