CVE-2014-8117

NameCVE-2014-8117
Descriptionsoftmagic.c in file before 5.21 does not properly limit recursion, which allows remote attackers to cause a denial of service (CPU consumption or crash) via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-131-1, DLA-145-1, DSA-2868-1, DSA-3121-1
NVD severitymedium
Debian Bugs773148

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)stretch (security), stretch1:5.30-1+deb9u3fixed
buster, buster (security)1:5.35-4+deb10u1fixed
bullseye1:5.38-5fixed
sid1:5.39-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesourcesqueeze5.04-5+squeeze9DLA-131-1
filesourcewheezy5.11-2+deb7u7DSA-3121-1
filesource(unstable)1:5.21+15-1low773148
php5sourcesqueeze5.3.3-7+squeeze24DLA-145-1
php5sourcewheezy5.4.4-14+deb7u8DSA-2868-1
php5source(unstable)5.6.4+dfsg-2

Notes

https://www.freebsd.org/security/advisories/FreeBSD-SA-14:28.file.asc
https://github.com/file/file/commit/6f737ddfadb596d7d4a993f7ed2141ffd664a81c
Other commits needed as well: https://www.openwall.com/lists/oss-security/2014/12/16/2

Search for package or bug name: Reporting problems