CVE-2014-8118

NameCVE-2014-8118
DescriptionInteger overflow in RPM 4.12 and earlier allows remote attackers to execute arbitrary code via a crafted CPIO header in the payload section of an RPM file, which triggers a stack-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-140-1, DSA-3129-1
NVD severityhigh (attack range: remote)
Debian Bugs773101

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rpm (PTS)wheezy, wheezy (security)4.10.0-5+deb7u2fixed
jessie4.11.3-1.1fixed
buster, sid, stretch4.12.0.2+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rpmsource(unstable)4.11.3-1.1high773101
rpmsourcesqueeze4.8.1-6+squeeze2highDLA-140-1
rpmsourcewheezy4.10.0-5+deb7u2highDSA-3129-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1168715

Search for package or bug name: Reporting problems