CVE-2014-8132

NameCVE-2014-8132
DescriptionDouble free vulnerability in the ssh_packet_kexinit function in kex.c in libssh 0.5.x and 0.6.x before 0.6.4 allows remote attackers to cause a denial of service via a crafted kexinit packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs773577

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libssh (PTS)wheezy, wheezy (security)0.5.4-1+deb7u3fixed
jessie (security), jessie0.6.3-4+deb8u2fixed
stretch0.7.3-2fixed
buster, sid0.8.0~20170825.94fa1e38-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsshsource(unstable)0.6.3-4medium773577
libsshsourcesqueeze(not affected)
libsshsourcewheezy0.5.4-1+deb7u3medium

Notes

[squeeze] - libssh <not-affected> (Issue only present in versions > 0.5.1, squeeze has 0.4.5)
http://www.libssh.org/2014/12/19/libssh-0-6-4-security-and-bugfix-release/
Upstream patch: http://git.libssh.org/projects/libssh.git/commit/?id=c2aed4ca78030d9014a890cb4370e6dc8264823f

Search for package or bug name: Reporting problems