CVE-2014-8138

NameCVE-2014-8138
DescriptionHeap-based buffer overflow in the jp2_decode function in JasPer 1.900.1 and earlier allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted JPEG 2000 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-121-1, DSA-3106-1
NVD severityhigh (attack range: remote)
Debian Bugs773463

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jasper (PTS)wheezy1.900.1-13+deb7u4fixed
wheezy (security)1.900.1-13+deb7u6fixed
jessie (security), jessie1.900.1-debian1-2.4+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jaspersource(unstable)1.900.1-debian1-2.3high773463
jaspersourcesqueeze1.900.1-7+squeeze3highDLA-121-1
jaspersourcewheezy1.900.1-13+deb7u2highDSA-3106-1

Search for package or bug name: Reporting problems