CVE-2014-8152

NameCVE-2014-8152
DescriptionApache Santuario XML Security for Java 2.0.x before 2.0.3 allows remote attackers to bypass the streaming XML signature protection mechanism via a crafted XML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml-security-java (PTS)stretch1.5.8-2fixed
stretch (security)1.5.8-2+deb9u1fixed
buster, buster (security)2.0.10-2+deb10u1fixed
bullseye (security), bullseye2.0.10-2+deb11u1fixed
bookworm, sid2.1.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml-security-javasource(unstable)(not affected)

Notes

- libxml-security-java <not-affected> (streaming XML Signature support introduced in 2.0.0)
http://svn.apache.org/viewvc?view=revision&revision=1634334
http://santuario.apache.org/secadv.data/CVE-2014-8152.txt.asc

Search for package or bug name: Reporting problems