CVE-2014-8155

NameCVE-2014-8155
DescriptionGnuTLS before 2.9.10 does not verify the activation and expiration dates of CA certificates, which allows man-in-the-middle attackers to spoof servers via a certificate issued by a CA certificate that is (1) not yet valid or (2) no longer valid.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-180-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy, wheezy (security)2.12.20-8+deb7u5fixed
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch3.5.8-5+deb9u3fixed
stretch (security)3.5.8-5+deb9u1fixed
buster, sid3.5.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)2.9.10-1medium
gnutls26sourcesqueeze2.8.6-1+squeeze5mediumDLA-180-1
gnutls28source(unstable)(not affected)

Notes

- gnutls28 <not-affected> (Initial version 3.0.0-1 already contained the check based on 2.9.10)
Fixed by: https://gitlab.com/gnutls/gnutls/commit/897cbce62c0263a498088ac3e465aa5f05f8719c

Search for package or bug name: Reporting problems