CVE-2014-8156

NameCVE-2014-8156
DescriptionThe D-Bus security policy files in /etc/dbus-1/system.d/*.conf in fso-gsmd 0.12.0-3, fso-frameworkd 0.9.5.9+git20110512-4, and fso-usaged 0.12.0-2 as packaged in Debian, the upstream cornucopia.git (fsoaudiod, fsodatad, fsodeviced, fsogsmd, fsonetworkd, fsotdld, fsousaged) git master on 2015-01-19, the upstream framework.git 0.10.1 and git master on 2015-01-19, phonefsod 0.1+git20121018-1 as packaged in Debian, Ubuntu and potentially other packages, and potentially other fso modules do not properly filter D-Bus message paths, which might allow local users to cause a denial of service (dbus-daemon memory consumption), or execute arbitrary code as root by sending a crafted D-Bus message to any D-Bus system service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fso-datad (PTS)jessie, stretch0.12.0-3fixed
fso-deviced (PTS)jessie0.12.0-5fixed
stretch0.12.0-7fixed
fso-frameworkd (PTS)jessie0.9.5.9+git20110512-5fixed
stretch0.10.1-3fixed
fso-gsmd (PTS)jessie0.12.0-4fixed
stretch0.12.0-5fixed
fso-usaged (PTS)jessie, stretch0.12.0-3fixed
phonefsod (PTS)jessie, stretch0.1+git20121018-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fso-datadsource(unstable)0.12.0-3high
fso-devicedsource(unstable)0.12.0-5high
fso-frameworkdsource(unstable)0.9.5.9+git20110512-5high
fso-gsmdsource(unstable)0.12.0-4high
fso-usagedsource(unstable)0.12.0-3high
phonefsodsource(unstable)0.1+git20121018-2high

Notes

[wheezy] - fso-deviced <no-dsa> (Minor issue)
[wheezy] - fso-datad <no-dsa> (Minor issue)
[wheezy] - fso-frameworkd <no-dsa> (Minor issue)
[squeeze] - fso-frameworkd <no-dsa> (Minor issue)
[wheezy] - fso-gsmd <no-dsa> (Minor issue)
[wheezy] - fso-usaged <no-dsa> (Minor issue)
[squeeze] - fso-usaged <no-dsa> (Minor issue)
[wheezy] - phonefsod <no-dsa> (Minor issue)
[squeeze] - phonefsod <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems