CVE-2014-8184

NameCVE-2014-8184
DescriptionA vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs880621

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblouis (PTS)jessie2.5.3-3+deb8u1fixed
stretch3.0.0-3+deb9u4fixed
buster3.8.0-2fixed
bullseye, sid3.12.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblouissource(unstable)2.6.2-1880621
liblouissourcejessie2.5.3-3+deb8u1
liblouissourcewheezy(not affected)

Notes

[wheezy] - liblouis <not-affected> (Vulnerable code introduced in 2.5.0)
https://github.com/liblouis/liblouis/issues/425
https://bugzilla.redhat.com/show_bug.cgi?id=1492701
Introduced by: https://github.com/liblouis/liblouis/commit/26ca8619a29951d6b4acf8b7a732a8b35e4e7bd3 (liblouis_2_5_0)
Fixed in merge: https://github.com/liblouis/liblouis/commit/dc97ef791a4fae9da11592c79f9f79e010596e0c#diff-7ade83431f79d2120c82012aee3b05c9L4524
CVE is for several buffer overflows in the findTable function, cf.
https://bugzilla.redhat.com/show_bug.cgi?id=1492701#c7

Search for package or bug name: Reporting problems