CVE-2014-8298

NameCVE-2014-8298
DescriptionThe NVIDIA Linux Discrete GPU drivers before R304.125, R331.x before R331.113, R340.x before R340.65, R343.x before R343.36, and R346.x before R346.22, Linux for Tegra (L4T) driver before R21.2, and Chrome OS driver before R40 allows remote attackers to cause a denial of service (segmentation fault and X server crash) or possibly execute arbitrary code via a crafted GLX indirect rendering protocol request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs772972, 772973

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)jessie/non-free340.106-1fixed
stretch/non-free384.130-1fixed
buster/non-free390.77-1fixed
sid/non-free390.87-2fixed
nvidia-graphics-drivers-legacy-304xx (PTS)jessie/non-free304.137-0~deb8u1fixed
stretch/non-free304.137-5~deb9u1fixed
sid/non-free304.137-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssource(unstable)340.65-1high
nvidia-graphics-drivers-legacy-173xxsource(unstable)(unfixed)high772973
nvidia-graphics-drivers-legacy-304xxsource(unstable)304.125-1high
nvidia-graphics-drivers-legacy-96xxsource(unstable)(unfixed)high772972

Notes

[wheezy] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[squeeze] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[wheezy] - nvidia-graphics-drivers-legacy-173xx <no-dsa> (Non-free not supported)
[squeeze] - nvidia-graphics-drivers-legacy-173xx <no-dsa> (Non-free not supported)
[wheezy] - nvidia-graphics-drivers-legacy-96xx <no-dsa> (Non-free not supported)
[squeeze] - nvidia-graphics-drivers-legacy-96xx <no-dsa> (Non-free not supported)

Search for package or bug name: Reporting problems