CVE-2014-8321

NameCVE-2014-8321
DescriptionStack-based buffer overflow in the gps_tracker function in airodump-ng.c in Aircrack-ng before 1.2 RC 1 allows local users to execute arbitrary code or gain privileges via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs767979

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
aircrack-ng (PTS)bullseye1:1.6+git20210130.91820bc-1fixed
bookworm1:1.7-5fixed
sid1:1.7+git20230807.4bf83f1a-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aircrack-ngsource(unstable)1:1.2-0~beta3-2767979

Notes

https://github.com/aircrack-ng/aircrack-ng/commit/ff70494dd389ba570dbdbf36f217c28d4381c6b5
https://github.com/aircrack-ng/aircrack-ng/pull/13

Search for package or bug name: Reporting problems