CVE-2014-8350

NameCVE-2014-8350
DescriptionSmarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-452-1
NVD severityhigh (attack range: remote)
Debian Bugs765920

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)jessie (security), jessie3.1.21-1+deb8u2fixed
stretch (security), stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1fixed
buster, sid3.1.33+20180830.1.3a78a21f+selfpack1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smartysource(unstable)(not affected)
smarty3source(unstable)3.1.21-1high765920
smarty3sourcesqueeze(unfixed)end-of-life
smarty3sourcewheezy3.1.10-2+deb7u1highDLA-452-1

Notes

- smarty <not-affected> (Only affects 3.x series)
[squeeze] - smarty3 <end-of-life> (Unsupported in squeeze-lts)
https://github.com/smarty-php/smarty/commit/279bdbd3521cd717cae6a3ba48f1c3c6823f439d.patch

Search for package or bug name: Reporting problems