CVE-2014-8355

NameCVE-2014-8355
DescriptionPCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-242-1, DLA-960-1
NVD severitymedium
Debian Bugs767240, 778238

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)stretch (security), stretch1.3.30+hg15796-1~deb9u4fixed
buster, buster (security)1.4+really1.3.35-1~deb10u1fixed
bullseye, sid1.4+really1.3.35+hg16348-1fixed
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.20-3+deb8u1778238
imagemagicksourcesqueeze8:6.6.0.4-3+squeeze6DLA-242-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u13DLA-960-1
imagemagicksource(unstable)8:6.8.9.9-1767240

Notes

[squeeze] - imagemagick <no-dsa> (Minor issue)
https://int21.de/cve/CVE-2014-8355-pcx-oob-heap-overflow.html
[wheezy] - graphicsmagick <no-dsa> (Minor issue)
[squeeze] - graphicsmagick <no-dsa> (Minor issue)
http://sourceforge.net/p/graphicsmagick/code/ci/4426024497f9ed26cbadc5af5a5de55ac84796ff/ (graphicsmagick)

Search for package or bug name: Reporting problems