CVE-2014-8417

NameCVE-2014-8417
DescriptionConfBridge in Asterisk 11.x before 11.14.1, 12.x before 12.7.1, and 13.x before 13.0.1 and Certified Asterisk 11.6 before 11.6-cert8 allows remote authenticated users to (1) gain privileges via vectors related to an external protocol to the CONFBRIDGE dialplan function or (2) execute arbitrary system commands via a crafted ConfbridgeStartRecord AMI action.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs771463

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)jessie1:11.13.1~dfsg-2+deb8u5fixed
jessie (security)1:11.13.1~dfsg-2+deb8u6fixed
stretch (security), stretch1:13.14.1~dfsg-2+deb9u4fixed
buster, sid1:16.1.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:13.1.0~dfsg-1medium771463
asterisksourcejessie1:11.13.1~dfsg-2medium
asterisksourcesqueeze(unfixed)end-of-life
asterisksourcewheezy(not affected)

Notes

[wheezy] - asterisk <not-affected> (Only affects 11.x, 12.x and 13.x)
[squeeze] - asterisk <end-of-life> (Unsupported in squeeze-lts)
https://issues.asterisk.org/jira/browse/ASTERISK-24490
http://downloads.digium.com/pub/security/AST-2014-017.html

Search for package or bug name: Reporting problems