CVE-2014-8501

NameCVE-2014-8501
DescriptionThe _bfd_XXi_swap_aouthdr_in function in bfd/peXXigen.c in GNU binutils 2.24 and earlier allows remote attackers to cause a denial of service (out-of-bounds write) and possibly have other unspecified impact via a crafted NumberOfRvaAndSizes field in the AOUT header in a PE executable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-184-1, DSA-3123-1, DSA-3123-2
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
binutils (PTS)wheezy2.22-8+deb7u2fixed
wheezy (security)2.22-8+deb7u3fixed
jessie2.25-5+deb8u1fixed
stretch2.28-5fixed
buster, sid2.29.1-12fixed
binutils-mingw-w64 (PTS)wheezy, wheezy (security)2+deb7u1fixed
jessie5.2+deb8u1fixed
buster, sid, stretch7.4fixed
gdb (PTS)wheezy7.4.1+dfsg-0.1vulnerable
jessie7.7.1+dfsg-5vulnerable
buster, sid, stretch7.12-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
binutilssource(unstable)2.24.90.20141104-1high
binutilssourcesqueeze2.20.1-16+deb6u1highDLA-184-1
binutilssourcewheezy2.22-8+deb7u2highDSA-3123-1
binutils-mingw-w64source(unstable)5.2high
binutils-mingw-w64sourcewheezy2+deb7u1highDSA-3123-2
gdbsource(unstable)(unfixed)unimportant

Notes

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=7e1e19887abd24aeb15066b141cdff5541e0ec8e

Search for package or bug name: Reporting problems